
Exercício 2 

Neste exercício serão praticadas operações de seleção espacial, e de seleção por atributos, 
envolvendo elementos do banco de dados criado no exercício anterior. 

Parte I – Seleção Espacial 

A Figura 1 indica as operações a serem feitas a seguir: (1.1) seleção (espacial) dos distritos com 
estação(ões) de metro (operadas pelo Metrô e/ou ViaQuatro) em seu território; (1.2) seleção 
(espacial) adicional dos distritos que possuem estação(ões) de trem (Operadas pela CPTM e/ou 
ViaMobilidade) em seu território; (1.3) criar nova camada (layer) para esses distritos (com 
alguma estação); e (1.4) criar camada (layer) complementar para os distritos sem estação 
alguma. 

Figura 1 – Operações de seleção espacial e da exportação de dados 
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A convenção de notação usada no diagrama da Figura 1, e que será adotada doravante é: 
- paralelogramo – indica camada de dados espaciais; Nota-se a indicação do tipo de dado 
espacial, em cada paralelogramo, na forma de um estereótipo; 
- retângulo – indica processamento de dados, genericamente definido; Genericamente, por 

não indicar a sintaxe particular de um software; O símbolo σ (sigma) indica que se trata de 
uma seleção com base num predicado, indicado entre os parênteses; 
- linha com seta cheia - entrada de dados para um processo, ou saída de dados de um 
processo; 
- linha com seta aberta - indica (conjunto de) dados apontados, resultante do processo de 
seleção; 
- figura com lados opostos curvados na mesma direção – indica dado externo lido (importado) 
ou gerado (exportado) por um processo. 

No diagrama da Figura 1, a operação (1.2) agrega eventuais distritos com estações de trem, 
mas sem estações de metro, ao conjunto seleção resultante da operação (1.1). Daí o símbolo 
(+) na seta correspondente. 

Abrir o projeto criado no exercício anterior 

 Project > Open 
 navegar até a pasta de trabalho e selecionar e abrir o projeto 
  AUT5826 – Exercicio 1.qzg 

Selecionar os distritos com estações de metro em seu território (1.1) 

Trata-se de consulta espacial 

Sua seleção na interface do QGIS, assim como outras ferramentas, pode variar de versão para 
versão. 

No menu superior, selecionar: Vector > Research Tools > Select by Location 

Preencher os campos: 

Select features from: DistritosCEM [EPSG:31983] 
where the features (geometric predicate) 
 [√] contain 
By comparing to the features from: estacao_metro [EPSG: 31983] 
Modify current selection by: creating new selection 

Executar a consulta especial pelo botão [ Run ] 

Ela será rápida se os Distritos tiverem sido previamente indexados espacialmente. 

Apenas desbloquear e/ou redimensionar a janela Select by Location para visualizar o mapa e 
observar distritos selecionados – com estações de metro em seus territórios. 

Selecionar também os distritos com estações de trem em seu território (1.2) 

Proceder de forma semelhante com relação às estações de trem, mas com o cuidado de 
indicar que se deseja acrescer novos distritos aos já selecionados: 

… 
By comparing to the features from: estacao_trem [EPSG: 31983] 
Modify current selection by: adding to current selection 

Executar novamente a consulta com [ Run ] 



Fechar a janela Select by Location para visualizar o mapa e observar distritos selecionados – 
com ao menos uma estação do sistema metroferroviário. 

Observar no canto inferior esquerdo da tela, o número de distritos selecionados. 

Criar lista dos distritos que contenham alguma estação do sistema metroferroviário (1.3) 

 DistritosCEM > Export > Save Selected Features as… 

Na tela de exportação, pode-se optar entre gerar nova camada de dados espaciais em diversos 
formatos, assim como apenas seus dados alfanuméricos, na forma de texto. 

Pede-se uma lista com seus nomes, etc., exceto o fid: 

 Format: Coma Separated Value (CSV) 
 File name: […] navegar até a pasta de trabalho e salvar como 
  distritos-com-estacoes.csv 
 Encoding: UTF-8 
 [v] Save Only selected features 

 Select Fields to export and their export options 
 [  ] fid – desmarcar fid 
 [v] IBGECOD – marcar os demais 
 … 
 [v] MUNNOME 

 Layer Options 
  SEPARATOR SEMICOLON 
  STRING_QUOTING ALWAYS 

 [   ] add saved file to map – desmarcar 

 [OK] 

Verificar no topo da tela se a operação foi indicada como bem sucedida, assim como a pasta 
onde o arquivo foi gravado. 

O resultado pode ser aberto com editor de texto simples. Segue uma cópia parcial do 
conteúdo. 

"IBGECOD";"SIGLA";"NOME";"NOMECAPS";"MUNSIGLA";"MUNNOME" 
"353060710";"BRC";"Brás Cubas";"BRAS CUBAS";"MJC";"MOJI DAS CRUZES" 
"353060705";"MJZ";"Moji das Cruzes";"MOJI DAS CRUZES";"MJC";"MOJI DAS CRUZES" 
"351880005";"GRZ";"Guarulhos";"GUARULHOS";"GRU";"GUARULHOS" 
"351640805";"FRZ";"Franco da Rocha";"FRANCO DA ROCHA";"FRO";"FRANCO DA ROCHA" 
"355030817";"CLM";"Campo Limpo";"CAMPO LIMPO";"SAO";"SAO PAULO" 
"355030894";"VSO";"Vila Sônia";"VILA SONIA";"SAO";"SAO PAULO" 

A lista pode ser carregada diretamente numa planilha eletrônica e ordenada, segundo 
quaisquer dos atributos. 

Criar lista com os distritos que não contém estações do sistema metroferroviário (1.4) 
(Aproveitar os distritos selecionados para gerar o conjunto inverso) 

No menu superior há um grupo de ícones denominado ‘Selection Toolbar’, com um grupo  
(clicar na seta  que aparece ao lado de um desses, para exibir os demais): 
 Select Features by Value... 
 Select features by Expression... 



 Select All Features 
 Invert Feature Selection 

Senão, clicar com o botão direito sobre a área das barras de ferramentas e selecionar da lista 
‘Toolbars’: 

 [v] Selection Toolbar 

O último inverte a seleção os distritos com estações de metro ou de trem em seu território, 
para distritos sem estações de metro ou de trem em seu território. 

O resultado no mapa é imediato. 

Exportar a nova lista, a exemplo da anterior. Segue cópia parcial. 

"IBGECOD";"SIGLA";"NOME";"NOMECAPS";"MUNSIGLA";"MUNNOME" 
"353060725";"TPB";"Taiaçupeba";"TAIACUPEBA";"MJC";"MOJI DAS CRUZES" 
"353060707";"BBU";"Biritiba-Ussu";"BIRITIBA USSU";"MJC";"MOJI DAS CRUZES" 
"354680105";"SIZ";"Santa Isabel";"SANTA ISABEL";"SIS";"SANTA ISABEL" 
"351830505";"GMZ";"Guararema";"GUARAREMA";"GMA";"GUARAREMA" 
"350660705";"BBZ";"Biritiba-Mirim";"BIRITIBA MIRIM";"BBM";"BIRITIBA MIRIM" 
"354500110";"NSR";"Nossa Senhora do Remédio";"NOSSA SENHORA DO 
REMEDIO";"SPS";"SALESOPOLIS" 
... 

Parte II – listar as estações de trem da RMSP fora do município de São Paulo 

Trata-se, neste caso, de exemplo de seleção por atributos, seguida por seleção espacial, ou 
seja, das estações de trem fora de distritos cujos MUNNOME sejam diferentes de ‘SAO 
PAULO’, ou MUNSIGLA diferentes de ‘SÃO’, conforme indicado na Figura 2. 



Figura 2 – Operações de seleção por atributo, seguida de seleção espacial e da exportação de 
dados 

 

Caso já não tiver feito, desmarcar os distritos selecionados na parte anterior deste exercício, 
com a ferramenta: 

 Deselect Features from the Current Active Layer – com a camada DistritosCEM 
apontada na lista 
 ou 
 Deselect Features from All Layers 

Seleção por atributo (2.1) 

 DistritosCEM > Filter... 

 Em Fields, duplo clique em MUNSIGLA 
 Em Operators, clicar [!=] (not equal) 
 Em Values clicar [ALL] e selecionar SAO da lista, com duplo clique 

 Observar em Specific Provider Filter Expression a expressão 

  “MUNSIGLA” != ‘SAO’ 
 [OK] 
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 Observar que os distritos do município de São Paulo não são exibidos no mapa, e de 
haver o símbolo de um filtro oposto a DistritosCEM, na lista de camadas. 

Seleção espacial (2.2) 

Vector > Research Tools > Select by Location… 

 Select features from: estacao_trem [EPSG:31983] 
 Where the features (geometric predicate) 
  [v] are within 
 By comparing to the features from: DistritosCEM [EPSG:31983] 
 Modify current selection by: creating new selection 
 [RUN] 

 Observar que apenas as estações de trem da RMSP, sem o município de São Paulo, 
foram selecionadas. 

Exportar a lista de estações (2.3) 

 estacao_trem > Export > Save Selected Features as… 

 Format: Coma Separated Value (CSV) 
 File name: […] navegar até a pasta de trabalho e salvar como 
  estacoes_trem_RMSP_sem_MSP.csv 
 Encoding: Windows-1252 (UTF-8 gerou acentuação incorreta) 
 [v] Save Only selected features 

 Select Fields to export and their export options 
 [  ] fid – desmarcar fid 
 [v] nm_estacao – marcar os demais, exceto cd_tipo_tr 
 … 
 [v] nm_empresa 
 [  ] cd_tipo_tr 

 Layer Options 
  SEPARATOR SEMICOLON 
  STRING_QUOTING ALWAYS 

 [   ] add saved file to map – desmarcar 

 [OK] 

Cópia parcial do resultado é exibida a seguir. 

"nm_estacao";"cd_identi1";"nm_linha_m";"nm_empresa" 
"GUARULHOS CECAP";"13";"JADE";"CPTM" 
"ITAPEVI";"8";"DIAMANTE";"VIAMOBILIDADE" 
"OSASCO";"8";"DIAMANTE";"VIAMOBILIDADE" 
"ANTONIO GIANETTI NETO";"11";"CORAL";"CPTM" 
"ANTÔNIO JOÃO";"8";"DIAMANTE";"VIAMOBILIDADE" 
"ARACARÉ";"12";"SAFIRA";"CPTM" 

Na lista de camadas, clicar sobre o filtro que aparece junto a DistritosCEM, seguido de [Clear] 
na janela de configuração do filtro. 



Parte III – Uso da calculadora de campo do QGis 

O processo efetuado na primeira parte deste exercício, é genérico, e pode ser feito de maneira 
similar em diversos software SIG. Entretanto, cada software tem suas especificidades. No caso 
do QGis, pode-se também fazer uso de um recurso chamado ‘calculadora de campo’. Tal 
calculadora, não apenas atribui valores a atributos (campos) com o uso de operadores e 
predicados alfanuméricos, como também permite o uso de predicados espaciais. 

Criar atributos indicativos da existência de estações de metro e de trem em cada distrito, 
conforme indicado na Figura 3. Observar os retângulos com barras verticais em cada lado, 
indicativos do processo ser específico ao software SIG em uso, o QGis, inclusive em termos da 
sintaxe das operações. 

Figura 3 – Criação e atribuição de valor a campos no QGis com a calculadora de campos 
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 [ Open field calculator] 

  [v] Create a new field 
  Output field name: com_metro 
  Output field type: Boolean 

  Expression 
   Geometry – expandir lista de predicados de geometria 
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 A Caixa de Texto ‘Expression’ onde a expressão de atribuição dos valores, no caso true 
ou false, ao atributo (campo) a criar, indica erro de sintaxe, pois espera que sejam fornecidos 
parâmetros opcionais adicionais e/ou que seja fechada a expressão iniciada com parênteses. 
Fechar os parênteses. 

   Overlay_contains 
 (‘estacao_metro_... ) 

 Abaixo da Caixa de Texto, pode-se selecionar distritos e pré-visualizar seus valores. 
Trata-se de uma forma de verificar se o resultado da aplicação da expressão será o pretendido. 

 Feature: Água Rasa 
 Preview: false 

 Feature: Barra Funda 
 Preview: true 

 [OK] 
 Observar na tabela de atributos de DistritosCEM, o novo campo, com valores de true 
ou false, para cada distrito. 

 [ Save Edits ] para salvar a alteração 

Ainda no modo de edição, repetir o processo para as estações de trem (3.2) 

DistritosCEM > Open Attribute Table 

 [ Open field calculator] 

  [v] Create a new field 
  Output field name: com_trem 
  Output field type: Boolean 

  Expression 
   Geometry – expandir lista de predicados de geometria 
   overlay_contains – duplo clique para selecionar 
   Geometry – retrair lista 
   Map Layers – expandir lista de camadas 
   estacao_metro – duplo clique para selecionar 

 A Caixa de Texto ‘Expression’ onde a expressão de atribuição dos valores, no caso true 
ou false, ao atributo (campo) a criar, indica erro de sintaxe, pois espera que sejam fornecidos 
parâmetros opcionais adicionais e/ou que seja fechada a expressão iniciada com parênteses. 
Fechar os parênteses. 

   Overlay_contains 
 (‘estacao_trem_... ) 

 Abaixo da Caixa de Texto, pode-se selecionar distritos e pré-visualizar seus valores. 
Trata-se de uma forma de verificar se o resultado da aplicação da expressão será o pretendido. 

 Feature: Água Rasa 
 Preview: false 



 Feature: Barra Funda 
 Preview: true 

 [OK] 
 Observar na tabela de atributos de DistritosCEM, o novo campo, com valores de true 
ou false, para cada distrito. 

 [ Save Edits ] - para salvar a alteração 

 [ Toggle editing mode ] - para encerrar as alterações 

 

Geração das listas de distritos com ou sem estação metroferroviária, após seleção por 
atributos, conforme indicado na Figura 4. 

Figura 4 -Geração das listas de distritos após seleção por atributo 

 

(3.3) 
Uma forma alternativa ao filtro, usado na segunda parte deste exercício, é a seleção dos 
distritos, mantendo-se visível ambos conjuntos. 

 Selecionar DistritosCEM na lista de camadas. 
 Na barra de ferramentas Selection Toolbar, acionar [ Select Features by Expression ] 
 Na janela DistritosCEM – Select by Expression 
   Fields and Values – expandir lista de atributos 
   com_metro– duplo clique para selecionar 

 (DistritosCEM.com_metro OR DistritosCEM.com_trem)
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   Operators – expandir lista de atributos 
   OR – duplo clique para selecionar 
  Fields and Values 
   com_trem– duplo clique para selecionar 

Abaixo da Caixa de Texto, pode-se selecionar distritos e pré-visualizar seus valores. Trata-se de 
uma forma de verificar se o resultado da aplicação da expressão será o pretendido. 

 Feature: Água Rasa 
 Preview: 0 

 Feature: Barra Funda 
 Preview: 1 

 [ Select Features ] 

Observar no mapa, a seleção dos distritos com estação de metro e/ou trem. 

(3.4) a (3.6) 

Proceder, como na primeira parte do exercício, para gerar as listas. 

 

Parte IV – Primeiro Exercício para Avaliação 

Pede-se, a exemplo dos exercícios anteriores: 

(A.1.1) Produzir a lista de distritos com estação de metro E estação de trem nos limites do seu 
território. Para constar da lista, tem de conter, ao menos, uma estação de cada sistema (metro 
e trem). 

(A.1.2) Produzir a lista de estações de trem que estejam fora da RMSP. 

Em cada caso, indicar, considerando o GeoPackage no estado correspondente, ao menos, ao 
final da Parte II do Exercício 2, entregar: 

(a) Diagrama operacional do processo (elaborar antes de executar as operações no software 
SIG escolhido*); 

(b) Roteiro detalhado de todo o procedimento, que permita outra pessoa executá-lo, no 
software SIG indicado*; 

(c) Listas geradas em formato CSV, que possam ser carregadas diretamente por software de 
planilha eletrônica. 

* Pode ser usado outro software SIG que não o QGis, como, por exemplo, ArcGis, TerraView, 
MapInfo, etc., desde que se consiga usar o GeoPackage criado e usado nos exercícios 
anteriores. 


